Помогите пожалуйста, очень срочно нужно решение задачи буду очень балагодарен завтра итоговая контрольная: Дан массив чисел d[i],в котором 7 элементов.Найти сумму четных элементов массива,и вычеслить среднее арифметическое всех элементов массива. Буду признателен, пишем на паскале, если можно напишите программу, или скиньте скрин!Очень жду

Const
n = 7;
var a: array [1..n] of integer; i, m0, m1: integer;
 begin
  m0:=0; m1:=0;
  writeln(Массив -->);
  for i:= 1 to n do readln(a[i]);
   for i:= 1 to n do begin
    m0:=m0+a[i];
    if a[i] mod 2 = 0 then m1:= m1+a[i];
  end;
 writeln(Cумма четных элементов массива: ,m1);
 writeln(Cреднее арифметическое всех элементов массива: ,m0/n);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку