Срочно!! Паскаль!! Напишите программу которая определяет является ли заданное натуральное числом квадратом некоторого натурального числа
Var
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln(YES)
else
writeln(NO);
end.
Оцени ответ
