Каждое утро майор Знаменский идет в тир и делает пять выстрелов через плечо. Если он набирает 50 очков, то вечером идет с Зиночкой в ресторан, а если меньше, то на тренировку в тир. Написать программу, которая выдает планы майора на вечер.В паскале

//Pascal ABC.NET v3.1 сборка 1219
//Как я понял, количество очков случайно

Var
 a,i,s:integer;
begin
 randomize;
 for i:=1 to 5 do
  begin
   a:=random(11);
   writeln(i, выстрел -,a);
   s:=s+a;
  end;
 writeln(Сумма=,s);
 if s=50 then writeln(Идет с Зиночкой в ресторан) else writeln(На тренировку в тир);
end.

Пример работы программы:
1 выстрел -3
2 выстрел -10
3 выстрел -7
4 выстрел -8
5 выстрел -0
Сумма=28
На тренировку в тир

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку