Написать программу. Задано натуральное число. Определить делится ли оно на два. Примечание: проверка делимости на 2 осуществляется следующим образом: пусть N-натуральное число. Если N/2=N2,то число делится на 2, иначе нет. (N/2-обычное деление, N2-деление нацело)

вообще признак делимости на 2 можно определить проще. Если остаток от деления на 2=0 тогда число делится на 2 нацело иначе нет if (n mod 2)=0  then writeln(Число  делится на 2 нацело ) else   writeln(Число не  делиться на 2 нацело );

Однако если по условию задачи признак, такой то уж ничего не пделаешь 

Program evenNum;

Uses crt;

var n:real;

begin

     clrscr; 

 

     write(Введите число n: );

     readln(n); 

 

     if ((n/2)<>(n div 2)) then writeln(Число не делится на 2 нацело )

                 else   writeln(Число  делится на 2 нацело ); 

    readkey;    

 

end. 

 

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку