Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n- вводится с клавиатуры) если n-четное, и сумму кубов чисел от 1 до n, если n-нечетное1 Использовать цикл REPEAT

var i,x,n:integer;

begin

i:=1;

writeln(Vvedit N);

readln(n);

if n mod 2 = 0 then begin

repeat

x:=i*i+x;

i:=i+1;

until i>n;

end

else begin

repeat

x:=i*i*i+x;

i:=i+1;

until i>n;

end;

writeln(x);

readln;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку