Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. Напишите программу, которая находит и выводит номер третьего положительного элемента массива (если из массива вычеркнуть все неположительные элементы, этот элемент стоял бы в получившемся массиве на третьем месте). Если в массиве меньше, чем три положительных элемента, вывести сообщение об этом.

const n=30;

var k:array[1..n] of integer; i,t,p:integer;

begin

randomize;

for i:=1 to n do begin

k[i]:=random(100);

if (k[i]>0) then p:=p+1;

if (i=3) and (k[3]>0) then t:=k[3];

end;

if (p<3) then write(В массиве меньше трех положительных элементов) else writeln(Третий элемент массива равен , t);

end.

 

Отрицательного значения в массиве не будет, напиши формулу к массиву k[i]:=твоя формула. Формула должна быть такой, чтобы попадались и отрицательные элементы, а так, программа рабочая

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку