написать программу(на ABC pascal), которая находит сумму четных цифр в введенном с клавиатуры натуральном числе меньше 30000)
Program Zn;
var n,k,sum:integer;
Begin
Writeln(Введите натуральное число);
Readln(n);
While n<>0 do begin
k:= n mod 10;
if k mod 2 = 0 then sum:=sum+k;
n:= n div 10;
end;
writeln(Сумма четных чисел = , sum);
end.
(Проверено и откомпелировано на Pascal.NET)
Оцени ответ
