Написать программу на языке Паскаля для вычисления S=1^1+2^2+3^3+...+n^n
var
n, i: integer;
s: real;
begin
readln(n);
for i := 1 to n do
s := s + exp(i*ln(i));
writeln(s);
end
Оцени ответ
Вход
Регистрация
Задать вопрос
Написать программу на языке Паскаля для вычисления S=1^1+2^2+3^3+...+n^n
var
n, i: integer;
s: real;
begin
readln(n);
for i := 1 to n do
s := s + exp(i*ln(i));
writeln(s);
end