1.Составьте программу нахождения наибольшего общего делителя трех чисел, используя следующую формулу:

НОД(А, B, С) = НОД(НОД(А, В), С)

function nod(a,b:integer):integer; 
begin if a mod b<>0 then nod:=nod(b,a mod b) else nod:=b end; 
var a,b,c:integer; begin readln(a,b,c); writeln(nod(nod(a,b),c)); readln end. 

 

 

 

 

 

 

 

                                                                                                                            p.s. я не уверен что это правильно

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку