Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

var
  a, i, count, s: integer;
begin
  repeat
    if(i = 100) then break;
    readln(a);
    if(abs(a) > 300) then begin
      writeln(Число по модулю не может быть > 300.);
      continue
    end
    else if(a mod 9 = 0) and (a <> 0) then begin
      inc(count);
      s := s + a;
    end;
    if(a <> 0) then inc(i);
  until(a = 0);
  writeln(Среднее арифметическое: , s / count);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку