Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале.

P.S формулы в программе быть не должно

var a:string;
i:integer;
c:boolean;
begin
readln(a);
repeat
if pos(+,a)<>0 then begin inc(i); delete(a,pos(+,a),1); end;
if pos(-,a)<>0 then begin inc(i); delete(a,pos(-,a),1); end;
if (pos(+,a)=0) and (pos(-,a)=0) then c:=true;
until c;
writeln(i);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку