Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью v километров в час. На какой отметке он остановится через t часов?
Программа получает на вход значение v и t. Если v0, то Вася движется в положительном направлении по МКАД, если же значение v0, то в отрицательном.
Программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится Вася.
Решение на pascal. Могут быть небольшие недочёты =)
Program avtorMaltsevaDY;
var
s, t, v, z :integer;
begin
s:=109;
writeln (Vvedite vremya);
readln (t);
writeln (Vvedite scorost);
readln (v);
z:=v*t;
if z>0 then
while z
z:=z-s;
end;
else
while (z>0) and (z
z:=z+s;
end;
Writeln (Vasya ostanivitsya na otmetke - , z);
end.
