Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу: А*В = НОД(А*В)*НОК(А, В). (по алгоритму Евклида на Паскале)

Var
    x, y, p: Integer;

begin
    Writeln(Введите два числа);
    Readln(x, y); {вводим два целых числа}
    p := x * y;
    
    repeat
        if x > y Then x := x Mod y
        Else y := y Mod x
    until (x = 0) Or (y = 0);
    {до тех пор, пока одно из чисел не станет равно нулю}
    
    Writeln(НОK=, p / (x + y)); {вывод НОД - без условного оператора, так как одно из чисел обязательно равно нулю}
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку