1)Как, используя функцию random(X), можно получать числа в диапазонах: от 1 до 10, от -10 до +10, от 50 до 100?

2) какие значения может принимать целая переменная Y если в программе записано : Y :=10+ ranodom (5)?

3) составьте программу заполнения массива из 100 чисел случайными значениями из диапозона от -20до 20. подсчитайте в этом массиве колличество положительных и колличество отрицательных значения

1.

random(10)+1;

random(21)-10;

random(100)+50;

2.y =[10;14]

3.

var

arr = array[1..100] of real;

rand : real;

i : integer;

p,n:integer;

begin

for i := 1 to 100 do

begin

arr[i] := random(41)-20;

i := i+1;

end;

for i :=1 to 100 do

begin 

if arr[i] <0 then

begin

n := n+1;

end;

if arr[i]>0 then

begin

p := p+1;

end;

end;

writeln("positives: ", p);

writeln("negatives: ",n);

readln;

end.

 

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку