. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln(сумма равна , S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln(наибольшее число , A); writeln(наименьшее число , C); end else writeln(a= ,a, b= , b, c= ,c);

var 

a,b,c,s:integer;

begin

readln(a,b,c);

 if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then

begin

S:=a+b+c; writeln(сумма равна , S);

end;

if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then

begin

writeln(наибольшее число , A);

writeln(наименьшее число , C);

end;

else

writeln(a= ,a, b= , b, c= ,c);

readln;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку