Напишите программу, которая задает трехмерный массив и находит в нем наибольшее число. ( pascal ). Буду очень рад, если прокомментируете, очень хочу разобраться.

const

  n = 3;

var

  a:array[1..n, 1..n, 1..n] of integer; //объявляем трехмерный массив размерности N x N x N

  i, j, k, max:integer;

begin

  randomize;

  max := -maxint - 1; {присваисваем maxrcbvfkmyjve ktvtyne минимальное возможное значения типа integer}

  for i := 1 to n do { с помощью трех циклов проходим по всем элементам массива, чобственно тоже самое что и с двумерным массивом только добаляемтся еще 1 цикл}

  begin

    writeln;

    writeln(i = , i); {выводм масссива производится в виде нескольких квадратных матриц тут указывается номер каждой квадратной матрицы}

    for j := 1 to n do

    begin

      for k := 1 to n do

      begin

        a[i, j, k] := random(21) - 10; // генерируем случайное значение от -10 до 10

        if a[i, j, k] > max then { если больше текущего максимального то станвится новым максимальным}

          max := a[i, j, k];

        write(a[i, j, k]:4); //выводим элемент массива

      end;

      writeln;

    end;

  end;

  writeln(Максимальный элемент массива равен , max);

end.

 

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку