Написать программу вычисления произведений в Паскаль 2*4*6*...*(2n).
ПОМОГИТЕ ПЛИЗЗЗ решить срочно

через рекурсию

 

var

function Product(N: Integer): Integer;

begin

if N = 1then

begin

Product := 2;

Exit;

end;

Product := 2 * N * Product(N - 1);

end;

 

 

var

N: Integer;

begin

ReadLn(N);

WriteLn(Product(N));

ReadLn;

end.

 

без рекурсии

 

N, Y, I: Integer;

 

begin

ReadLn(N); Y := 1; I := 0;

repeat

Inc(I);

Y := Y * 2 * I;

until I = N;

WriteLn(Y);

ReadLn;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку