составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов,формирует и выводит на экран в строку данный массив. Найти сумму неположительных элементов массива,количество элементов кратных 3, произведение элементов,стоящих на четных местах

program z1;
uses crt;
var m: array[1..10] of integer;
i,a,b,c:integer;
begin
for i:=1 to 10 do
readln(m[i]);
writeln;
a:=0;
b:=0;
c:=1;
for i:=1 to 10 do
begin
 if m[i]<=0 then a:=a+m[i];
if m[i] mod 3 = 0 then b:=b+1;
if i mod 2 = 0 then c:=c*m[i];
end;
writeln(Сумма отриц,a);
writeln(кратные 3,b);
writeln(произв,c)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку