Составить программу для паскаля: Найти сумму квадратов цифр целого числа. Количество цифр в числе не указан

Program summa_zifr;

Var S, X, A: integer;

begin

s:=0;

Write (Введите число для нахождения суммы);

Read (X);

While X<>0 do begin

A:= X mod 10;

S:= A * A + S;

X:= X div 10;

end;

Write (Сумма квадратов цифр числа" , X , =, S);

end.

 Сумма квадратов цифр числа - одинарный апостроф на конце предложения:)))

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку