Составить программу для вычисления функции Y=x^2 Sinx+1 на отрезке [0;1] с шагом h=0,1

const h=0.1;
var a, b, x, y: real;
begin
writeln(Otrezok [0,1] s shagom 0.1);
a:=0;
b:=1;
writeln(--------------------------);
writeln(| X | Y |);
writeln(--------------------------);
x:= a;
while x<= b do begin
y:=sqr(x)*sin(x)+1;
writeln(|, x:9:2, | , y:9:2, |);
x:= x+h;
end;
writeln(--------------------------);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку