Вводится строка текста из N символов,слова разделены одним пробелом.Найти длину самого длинного слова.Написать программу в Паскале.

var
i,k,l:integer;
s:string;
begin
readln(s);
k:=0;
i:=1;
while ibegin
  l:=0;
  while (s[i]<> ) and (i  begin
    l:=l+1;
    i:=i+1;
  end;
  i:=i+1;
  if l>k then k:=l;
end;
writeln(k);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку