Написать программу, которая находит все двузначные числа и их количество, которые делятся на n или содержат цифру n

#include
using std::cout;
using std::cin;
using std::endl;

int main()
{
    int n, counter = 0;

    cout << "Enter N: ";
    cin >> n;

    for(int i = 10; i < 100; i++)
    {
        if(i % n == 0 || i % 10 == n || i / 10 == n)
        {
            counter++;

            cout << i << ;
        }
    }

    cout << n << counter << " numbers" << endl;

   return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку