Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 кмч, выведите YES, иначе выведите NO.

Программа получает на вход число проехавших автомобилей N (1=

Программа должна сначала вывести максимальную скорость, затем YES или NO.

Написать на языке Паскаль

Пример работы программы: (смотри во вложениях)

var i,max,min,n:integer;
a:array[1..30] of integer;
begin cls; randomize;
max:=-1; min:=-1;
readln(N);
if ((n>=1) and ( n<=30)) then
begin
for i:=1 to N do a[i]:=random(300)+1;
//search max min +
max:=a[1];
min:=a[1];
for i:=1 to N do
begin
if (min> a[i]) then min:=a[i];
if (max < a[i]) then max:=a[i];
end;
//writeln(max, ,min);
// -
writeln(max speed = ,max);
for i:=1 to N do
if (a[i]<30) then writeln(avtomobil N= ,i, (YES) ne privyshal 30km/hour)
else
writeln(avtomobil N= ,i, (NO) privyshal > 30km/hour)
end
else
writeln(mnogo mashin!!);
readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку