Написать программу, которая в заданном одномерном массиве размерности N меняет местами соседние элементы, стоящие на чётных местах, с соседними элементами, стоящими на нечётных местах.

var a:array[1..10] of integer;
i,tmp:integer;

begin  cls;
 for i:=1 to 10 do a[i]:=i;
 
 for i:=1 to 10 do
 begin
 if i mod 2 = 1 then
 begin
 tmp:=a[i];
 a[i]:=a[i+1];
 a[i+1]:=tmp;
 end;
 
 end;
for i:=1 to 10 do
write(a[i], );

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку