Программа в Паскале!
"Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел . Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000."
Отдал все пункты что есть! Помогите!
uses System;
var ch,min,max,i:integer;
begin cls;
readln(ch);
min:=ch;
max:=ch;
while(ch<>0) do
begin
readln(ch);
if ((min > ch) and (ch<>0)) then min:=ch;
if max < ch then max:=ch;
inc(i);
if i > 999 then break;
end;
writeln(max = , max);
writeln(min= ,min);
writeln(suma max + min = ,max+min);
readln;
end.
