6. Написать программу тремя способами ( с циклами «ДО», «ПОКА» и с параметром ). Задача: Ввести n чисел. Найти сумму четных из них. Проанализируйте решения. Какое проще и почему?
uses crt;
var s,n,ch:integer;
begin
for i:=1 to n do
begin
if ch mod 2 = 0 then
s:=s+ch;
end;
end.
uses crt;
var s,n,ch,i:integer;
begin i:=1;
while i <=n do
begin
if ch mod 2 = 0 then
s:=s+ch; inc(i);
end;
end.
uses crt;
var s,n,ch,i:integer;
begin i:=1;
n:=5;
repeat
begin
readln(ch);
if ch mod 2 = 0 then
s:=s+ch; inc(i);
end;
until i>=n;
writeln(s);
end.
Оцени ответ
