Даны натуральное число n и последовательность целых чисел а1, а2,…,аn..Все положительные элементы уменьшить в 2 раза. Составить блок-схему алгоритма, написать программу

var a:array [1..1000] of real;

i,n:integer;

begin

readln(n);

for i:=1 to n do 

if a[i]>0 then a[i]:=a[i]/2;

for i:=1 to n do

writeln(a[i]);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку