Укажите наименьшее из таких чисел X, при вводе которых алгоритм печатает сначала 11, а потом 5.

var x, a, b, c: integer;

begin

readln(x); a:=0; b:=10;

while x>0 do

begin

c:=x mod 10;

a:= a+c;

if c

x:= x div 10;

end;

writeln(a); write(b);

end.

56 

потому что сумма цифр должна быть ровна 11

и наименьшая цифра=5 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку