помогите решить Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6. Пример работы программы: Входные данные Выходные данные 3 12 25 6 18 20.2
uses crt;
var i,ch,s,n:integer;
begin
s:=0;
readln(n);
for i:=1 to n do
begin
readln(ch);
if ch<301 then
begin
if ch mod 6 = 0 then s:=s+ch;
end else begin writeln(error); break; end;
end;
writeln;
writeln(s);
readln;
end.
Оцени ответ
