1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура
2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

Program Goodluck51_1;
uses crt;
var
  n,nt,sum,temp: integer;
begin
  write(Введите 5-значное число );
  readln(n);
  if (n<10000) or (n>99999) then write(Вы ввели неправильное число )
  else
    begin
      nt:=n;
      writeln(*** alphaues is thinking... ***);
      writeln(***          OK             ***);
      while n>=1 do
        begin
          temp:=n mod 10;
          sum := sum + temp;
          n := n div 10;
        end;
      writeln(Сумма цифр числа ,nt, равна ,sum);
    end;
end.

Program Goodluck51__2;
uses crt;
const n=4;
var
  a:array[1..n] of real;
  lt:array[1..n] of char;
  min,max: real;
  i:integer;
begin
  writeln(*** alphaues is thinking... ***);
  writeln(***          OK             ***);
  lt[1]:=a;
  lt[2]:=b;
  lt[3]:=c;
  lt[4]:=d;
  for i:=1 to n do
    begin
      write(Введите число ,lt[i],=);
      readln(a[i]);
    end;
  max:=a[1];
  min:=a[1];
  writeln(Числа: );
  for i:=1 to n do
    begin
      if a[i] > max then
        max:= a[i];
      if a[i] < min then
        min:=a[i];
      writeln(lt[i],=,a[i]);
     end;
  writeln(Полусумма наименьшего и наибольшего из них равна,(min+max)/2);
end.  

Program Goodluck51_3;
uses crt;
var
  n,nt,sum,temp: integer;
begin
  write(Введите число );
  readln(n);
  nt:=n;
  sum:=0;
  writeln(*** alphaues is thinking... ***);
  writeln(***          OK             ***);
  while n>=1 do
    begin
    temp:=n mod 10;
    sum := sum + temp;
    n := n div 10;
  end;
  writeln(Сумма цифр числа ,nt, равна ,sum);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×