Напишите программу, которая в последовательности натуральных
чисел определяет максимальное число, кратное 5. Программа
получает на вход количество чисел в последовательности, а затем сами
числа. В последовательности всегда имеется число, кратное 5.
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число – максимальное число, кратное 5.
Pascal
uses crt;
var a:array[1..1000] of integer;
i,max,n:integer;
begin
clrscr;
write(n<1000, n=);
read(n);
write(a[i]<30000, a[i]:);
for i:=1 to n do
begin
readln(a[i]);
max:=0;
if(a[i] mod 5=0) and (a[i]>max)
then max:=a[i];
end;
writeln(max=,max);
end.
Оцени ответ
