Написать программу, которая генерирует и выводит на экран массив из 10 случайных чисел в диапазоне от -100 до 100, меняет местами первую и вторую половину массива и выводит новый массив на экран.

#include
using std::cout;
using std::endl;
#include
using std::rand;
using std::srand;
#include
using std::time;

int main()
{
    int a[10];

    srand(time(0));

    for(int i = 0; i < 10; i++)
    {
        a[i] = rand() % 201 - 100;

        cout << a[i] << ;
    }
    cout << endl;

    int temp;
    for(int i = 0; i < 5; i++)
    {
        temp = a[i];
        a[i] = a[i + 5];
        a[i + 5] = temp;
    }

    for(int i = 0; i < 10; i++)
    {
        cout << a[i] << ;
    }
    cout << endl;

    return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку