Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов. предложения вводятся в одну строку. программа должна переписать введенную строку, оставив полько по одному пробелу между словами
PROGRAM Probel;
var s:string; n,i:integer;
begin
writeln (введите текст с пробелами );
readln(s); repeat inc(i);
n:=length(s);
if (s[i]= ) and ((s[i+1]= )) then
begin
delete (s,i,1);dec(i);
end;
until i=n;
writeln (удалены лишние пробелы );
writeln(s);
end.
Оцени ответ
