1. PASCAL. Даны три точки A(x1,y1), B(x2,y2), C(x3,y3). Написать программу, определяющую, которая из точек находится ближе к началу координат.

Проверено - работает на Паскаль АВС:

 

Program kovyarovsany;
var
  x1,y1,x2,y2,x3,y3:integer;
  d1,d2,d3:real;
begin
  write (X1 = );readln(x1);
  write (Y1 = );readln(y1);  
  write (X2 = );readln(x2);
  write (Y2 = );readln(y2);
  write (X3 = );readln(x3);
  write (Y3 = );readln(y3);  
  d1:=sqrt(x1*x1+y1*y1);
  d2:=sqrt(x2*x2+y2*y2);
  d3:=sqrt(x3*x3+y3*y3);
  if (d1=d2) and (d1=d3) then
      writeln (Все три точки на одинаковом расстоянии от начала координат )
    else
    if (d1=d2) and (d1      writeln (Точка 1 и точка 2 на одинаковом расстоянии от начала координат )
    else
      if (d2=d3) and (d2        writeln (Точка 2 и точка 3 на одинаковом расстоянии от начала координат )
      else
        if (d1=d3) and (d1          writeln (Точка 1 и точка 3 на одинаковом расстоянии от начала координат )
        else
          if (d1             writeln (Точка 1 ближе всех)
          else
            if (d2              writeln (Точка 2 ближе всех)
            else
               writeln (Точка 3 ближе всех);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку