Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

var a:array[1..1000] of longint;

 kol, s, i, n : longint;

begin

 

readln(n);

 

for i:=1 to n do read(a[i]);

 

s := 0;

kol := 0;

for i:=1 to n do 

begin

  if (a[i] mod 11 = 0) then s := s + a[i];  // summa elementov

  if (a[i] mod 2 = 1) then kol := kol + a[i];  // kolichestvo nechetnyx

end;

 

writeln (kol, , s);

end;

 

 

 

после //  нужно удалить ... сорри, что нет блок схемы

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку