Написать алгоритм и составить программу для вычисления суммы квадратов первых N членов натурального ряда.
Программа получает на вход N, почле чего в цикле постепенно обрабатывает все натуральные числа от 1 до N включительно и в ячейку памяти s откладывает их квадраты.
program summa;
uses crt;
var N,a,s,i: integer;
begin
read(N); a:=0; s:=0;
for i:=1 to N do
begin
a:=a+1;
s:=s+(a*a);
end;
writeln(s);
end.
Оцени ответ
