Помогите написать программу для Pascal ABC для нахождения корней дискриминанта

program z1; 
var a,b,c,D:real; 
begin 
writeln(Vvedite a); 
readln(a); 
writeln(Vvedite b); 
readln(b); 
writeln(Vvedite c); 
readln(c); 
D:=(b*b)-(4*a*c); 
writeln(Discriminant); 
writeln(D:1:2); 
D:=(-b+sqrt(D))/(2*a); 
writeln(1 koren); 
writeln(D:1:2); 
D:=(-b-sqrt(D))/(2*a); 
writeln(2 koren); 
writeln(D:1:2); 
readln 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку