Напишите программу, которая в последовательности натуральных
чисел определяет количество чисел, оканчивающихся на 3.
Программа получает на вход количество чисел в последовательности, а затем
сами числа. В последовательности всегда имеется число, оканчивающееся
на 3.
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число – количество чисел, оканчивающихся
на 3.

var

n:word;

a,i,k:integer;

begin

while (n<=0) or (n>1000) do begin 

write (0

end; 

repeat

readln(a);

if a mod 10 = 3 then k:=k+1; 

i:=i+1; 

until i=n;

writeln (---------------------------------------------------); 

writeln (k);

readln;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку