напишите программу которая в последовательности натуральных чисел определяет минимальное число кратное 3.

знаю как написать программу для максимального числа

var

a:integer;

b:longint;

begin

b:=0;

readln(a);

while (a<>0) do

begin

if ((a mod 3=0) and (a>b)) then

b:=a;

readln(a);

end;

writeln(b);

readln

end.

как для минимального??

В общем, это то же самое, что и для максимального, только вначале ты присваиваешь переменной min значение первого числа последовательности, а потом сравниваешь с этим числом все остальные. Смотри:

 

В Паскале:

Var a, i, mix, N: integer;

Begin

 Write (Введите количество чисел в последовательности ); readln (N);

 Write (Введите первое число последовательности ); readln (a);

 min:=a;

 for i:=1 to N do

 begin

  Write (Введите следующее число последовательности ); readln (a);

  if (a mod 3 = 0) and (a

 end;

 Writeln (Минимальное число, кратное 3 в последовательности равно , min);

End.

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку