Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3. Пример работы программы: Входные данные Выходные данные 3 23 13 23 3

n - кол-во чисел
i  - цикловая переменная
а - число
max - максимальное число, оканчивающееся на 3
Язык програмирования: Паскаль.
var
n,i,a,max: integer;
begin
readln(n);
max := -1;
for i := 1 to n do
begin
readln(a);
if (a mod 10 = 3) and (a > max) then
max := a;
end;
writeln(max)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку