Напишите программу поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).

var

a:array [1..30] of integer;

i,k,s:integer;

begin

randomize;

for i:=1 to 30 do begin

a[i]:=random(9)+1;

write (a[i], );

end;

s:=a[1]+a[2]; 

k:=1; 

for i:=2 to 29 do

if a[i]+a[i+1]>s then begin

k:=i;

s:=a[i]+a[i+1];

end; 

writeln; 

writeln (Number: ,k);

readln;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку