Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Паскаль
var
n:word;
a,max,i:integer;
begin
repeat
write (N = );readln(n);
until (n>0) and (n<=1000);
write (A = );readln(a);
if a mod 5 = 0 then max:=a;
while i<>n-1 do begin
write (A = );readln(a);
if (a>max) and (a mod 5 = 0) then max:=a;
i:=i+1;
end;
writeln (Max: ,max);
readln;
end.
Оцени ответ
