Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число кратное 6. Кол-во чисел не превышает 100. Введённые числа не привышают 300. Программа должна ввести одно число - сумму чисел кратных 6

Паскаль

 

var a,s,n,i:integer;
begin
  s:=0;
  write(kol-vo chisel:); read(n);

  if n>100 then writeln(error!);

  begin
    writeln(vvedite chisla);
    for i:=1 to n do
    begin
      read(a);

      if a>300 then write(error!);

      if (a mod 6=0) then s:=s+a;
    end;
    write(summa=,s);
  end;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку