Напишите программу, которая в последовательности целых чисел определяет количество трехзначных чисел, кратных 7. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000. Про-грамма должна вывести одно число: количество трехзначных чисел, кратных 7
uses crt;
var ch,i,n,count:integer;
begin
n:=0;
count:=0;
write( Введите число : );
readln(ch);
if ((abs(ch)<30000) and (ch div 100 <> 0 ) and (ch mod 7 = 0)) then inc(count);
while ((ch<>0) and ( n <1001)) do
begin
write( Введите число : );
readln(ch);
if ((abs(ch)<30000) and (ch div 100 <> 0 ) and (ch mod 7 = 0)) then inc(count);
inc(n);
end;
writeln(count);
readln;
end.
