Составить программу, которая выводит на экран меню:

1) первое;

2) второе;

3) третье;

и в зависимости от выбранного пункта выдаёт одну из надписей: «Получите суп», «Получите картошку», «Получите компот», «Оставайтесь голодным». Написать два варианта программы: с использованием условного оператора if и с использованием переключателя.



Program Atatushka1;
uses crt;
var
  M:Integer;
begin
  writeln(***************************************);
  writeln(*    Мы рады приветствовать вас       *);
  writeln(*         в нашем ресторане           *);
  writeln(*         A T A T U S H K A           *);
  writeln(*               ! ! !                 *);
  writeln(***************************************);
  writeln();
  writeln(***************************************);
  writeln(*              М Е Н Ю :              *);
  writeln(*  1. Первое                          *);
  writeln(*  2. Второе                          *);
  writeln(*  3. Третье                          *);
  writeln(*                                     *);
  writeln(***************************************);
  writeln();
  writeln(Введите номер желаемого блюда:);
  readln(M);
  writeln();
  if m=1 then
      writeln(Получите суп)
    else
      if m=2 then
          writeln(Получите картошку)
        else
          if m=3 then
              writeln(Получите компот)
            else
              writeln(Оставайтесь голодным);
end.

Program Atatushka2;
uses crt;
var
  M:Integer;
begin
  writeln(***************************************);
  writeln(*    Мы рады приветствовать вас       *);
  writeln(*         в нашем ресторане           *);
  writeln(*         A T A T U S H K A           *);
  writeln(*               ! ! !                 *);
  writeln(***************************************);
  writeln();
  writeln(***************************************);
  writeln(*              М Е Н Ю :              *);
  writeln(*  1. Первое                          *);
  writeln(*  2. Второе                          *);
  writeln(*  3. Третье                          *);
  writeln(*                                     *);
  writeln(***************************************);
  writeln();
  writeln(Введите номер желаемого блюда:);
  readln(M);
  writeln();
  case m of
    1: writeln(Получите суп);
    2: writeln(Получите картошку);
    3: writeln(Получите компот);
    else writeln(Оставайтесь голодным);
  end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку