Напишите программу для решения следующей задачи . Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведи YES, иначе выведите NO. Программа получает на вход число проехавших автомобилей N ( 1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести максимальную скорость, затем YES или NO.

Program N198453627;
uses crt;
var
  n,i:integer;
  max,v:real;
  yes: string;
begin
  writeln(*** alphaues is thinking... ***);
  writeln(***          OK             ***);
  max:=0;
  yes:=NO;
  writeln(Введите количество машин (не больше 30 - у меня мало памяти!));
  write(N = );
  readln(n);
  if n>30 then
      writeln(Это слишком много!)
    else
      begin
        writeln(Вводите зарегистрированную скорость каждого автомобиля);
        for i:=1 to n do
          begin
            write(i,-й автомобиль: );
            readln (v);
            if v >300 then
                begin
                  writeln (По-моему, твои приборы плохо отрегулированы - так быстро машины не ездят!);
                  writeln (Это число не будет учтено);
                end
              else
               if v < 1  then
                begin
                  writeln (Ты точно умеешь измерять скорость автомобиля? Скорость не может быть меньше 1!);
                  writeln (Это число не будет учтено);
                end
              else
                begin  
                  if v<30 then yes:=YES;
                  if v>max then max:=v;
                end;
          end;
        writeln();
        writeln(Максимальная зарегистрированная скорость: ,max);
        writeln(Cкорость меньше 30 км/ч? ,yes);
      end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку