16. Составить программу для вывода двух массивов, первый из которых состоит из отрицательных элементов и задаётся вручную, второй- состоит из нечётных элементов и задаётся функцией случайного выбора.
20)Составить массив из 10 отрицательных чисел. Вывести второй массив, состоящий из элементов певого массива, умноженных на введенное число.
Все в ТуброПаскале:)
1)
var
a,b:array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do begin
repeat
write (A[,i,] = );readln(a[i]);
if a[i]>0 then writeln (Error!);
until a[i]<0;
end;
writeln (First massiv: );
for i:=1 to 10 do write (a[i]:4);
writeln;
writeln (Second massiv: );
i:=1;
repeat
b[i]:=random(38)+3;
if odd(b[i])=true then i:=i+1;
until i>10;
for i:=1 to 10 do write (b[i]:4);
writeln;
readln;
end.
2)
var
a,b:array [1..10] of integer;
i,k:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(15)-15;
write (a[i]:4);
end;
writeln;
write (Number: );readln(k);
for i:=1 to 10 do begin
b[i]:=a[i]*k;
write (b[i]:4);
end;
writeln;
readln;
end.
