Гнездо для ножки деревянной кровати имеет форму прямоугольной вырезки. Определить, подойдет ли данный четырехугольный брусок для этого гнезда.
Если для этого нужно написать программу, то смотри(Паскаль):
uses crt;
var a,b,c,d,p,p1:real;
begin
clrscr;
write(длина вырезки );read(a);
write(ширина вырезки );read(b);
p:=2*(a+b);
write(длина сечения бруска );read(c);
write(ширина сечения бруска );read(d);
p1:=2*(c+d);
writeln;
if (p=p1) then
begin
if (c=a) or (c=b) then write(подойдет)
else write(не подойдет);
end
else write(не подойдет);
end.
Оцени ответ
