Дана матрица А(n×m). Получить вектор b1, b2, …, bn, где bi равно произведениям элементов строк. Составить программу на языке Basic

Правильность не гарантирую, потому что проверить в данный момент код негде.

 

Sub название

Dim A() As Integer
Dim b() As Integer
Dim i, j As Integer

 

Задаем размерность массива
Console.WriteLine ("Введите количество строк")
n = Console.ReadLine                                             
Console.WriteLine ("Введите количество столбцов")
m = Console.ReadLine


ReDim A(n, m) As Integer
ReDim b(n) As Integer

 

Цикл ввода данных
For i = 1 To n
For j = 1 To m
Console.WriteLine ("Введите число")
A(i, j) = Console.ReadLine
Next j
Next i

 

Все элементы массива b изначально делаем единичными, чтобы при умножении они не повлияли на значение
For i = 1 To n
b(i) = 1
Next i

 

Цикл вычисления каждого элемента массива b
For i = 1 To n
For j = 1 To m
b(i) = b(i) * A(i, j)
Next j
Next i

 

Вывод результата на экран
For i = 1 To n
Console.Write (b(i))
Next i
End Sub

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку