3. Составьте алгоритм вычисления значений функций для значений x=1, 2, 3, 4 …..10

В условии не указано, для какой именно функции вычислять значения. Я сочинил свою :)

Если тебе нужна другая функция, замени строку   y:=(2*sin(x)+7*x*x)/sqrt(x); на то, что тебе нужно.

 

Program L1e2na_2;
uses crt;
var
  x:integer;
  y:real;
begin
  writeln(+---------------------------------------+);
  writeln(|           КАКАЯ-ТО ФУНКЦИЯ            |);
  writeln(|      Вычисление значения функции      |);
  writeln(|       для Х = 1, 2, 3, ... , 10       |);
  writeln(+---------------------------------------+);
  writeln();
  writeln(+---------------------------------------+);
  writeln(|              Результат:               |);
  writeln(+---------------------------------------+);
  writeln(|         X         |         Y         |);
  writeln(+---------------------------------------+);
  for x:=1 to 10 do
    begin
      y:=(2*sin(x)+7*x*x)/sqrt(x);
      writeln(|  ,x:8,         | ,y:11:3,       | );
    end;
  writeln(+---------------------------------------+);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку